WhatsApp & Meta Service Disruption

Incident Report for Glassix

Resolved

This incident has been resolved.
Posted Jul 19, 2026 - 10:23 UTC

Update

Meta is currently operating normally; we continue to monitor closely.
Posted Jul 19, 2026 - 09:54 UTC

Update

We are continuing to investigate this issue.
Posted Jul 19, 2026 - 08:45 UTC

Investigating

We're aware of a wider Meta outage currently affecting WhatsApp, Facebook, Instagram, and Messenger. As a result, some messages on these channels may be delayed or fail to send/receive. We're monitoring and will update once it's resolved.
Posted Jul 19, 2026 - 08:40 UTC
This incident affected: Channels (WhatsApp, Facebook).