Degraded Search Performance

Incident Report for Glassix

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 13:02 UTC

Monitoring

A fix has been deployed and search latency has returned to normal levels. We're monitoring to confirm full recovery across conversations and canned replies.
Posted Jun 22, 2026 - 07:42 UTC

Investigating

Search — Conversations, Search — Canned Replies
We're currently investigating elevated latency affecting search across the platform. Users may experience slow or delayed results when searching within conversations and when searching canned replies. Other functionality remains unaffected, and no data is at risk.
Our team is actively working to identify the cause and restore normal performance. We'll post the next update within 30 minutes or as soon as we have more information.
Posted Jun 22, 2026 - 07:37 UTC
This incident affected: Glassix Web Application.