We have identified the issue and are continuing to work towards a resolution.
Please subscribe to this incident or follow along with this page for further updates.
Posted Aug 04, 2025 - 07:25 UTC
Investigating
We are aware of delays in updating delivery statuses (2 checkmarks) for messages in all channels. Our engineers are currently investigating the issue. Please be aware that this will also impact non-ticket delivery status webhook events.
Please subscribe to this incident or follow along with this page for further updates.
Posted Aug 04, 2025 - 06:46 UTC
This incident affected: Channels (WhatsApp, Web Chat Widget, Text Message, Email, Messenger, Mobile Chat, Facebook, Instagram, Instagram Direct) and Glassix Webhooks.