Degraded Search Performance

Incident Report for Glassix

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 18:30 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 08, 2025 - 18:22 UTC

Monitoring

We have implemented a fix and are monitoring the results. Search results are expected to slowly become available over the next few hours.

Please follow along with this page for further updates.
Posted Jul 08, 2025 - 14:35 UTC

Update

Our engineers have confirmed that the issue is currently only affecting newly created items. Tickets, canned replies and other searchable items from earlier today and before remain searchable as normal.

Please continue to follow this page for additional updates.
Posted Jul 08, 2025 - 14:08 UTC

Identified

We have identified an issue which is causing intermittently degraded performance across search bars in the Glassix Web Application, and our engineering team is currently working towards a resolution.

The issue is exclusively with search functions in the agent view, all other functionality across the API, webhooks and the web application is performing as expected. No customer-facing channels have been impacted.

Please follow this page for further updates.
Posted Jul 08, 2025 - 13:57 UTC
This incident affected: Glassix Web Application.