Degraded System Performance

Incident Report for Glassix

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 10:19 UTC

Monitoring

We have identified the root cause of the issue and have implemented a fix.

We are seeing gradual improvements to service availability as we continue to work towards a full resolution of the issue.

If you are still having trouble accessing the system, please try refreshing the page before reaching out to your support contact.
Posted Mar 09, 2026 - 10:18 UTC

Update

We no longer expect resolution efforts to impact the Glassix API.

Please continue to follow along with this page for updates.
Posted Mar 09, 2026 - 09:11 UTC

Update

We are continuing to investigate the issue, including reports of 504 errors.

Please be aware that the Glassix API will be periodically unavailable as we work to resolve the issue.

We will update this page with further information.
Posted Mar 09, 2026 - 09:02 UTC

Identified

We have received reports of degraded system performance. Our engineers are currently working to resolve the issue.

Please follow along with this page for additional updates.
Posted Mar 09, 2026 - 08:50 UTC
This incident affected: Glassix APIs, Glassix Webhooks, Glassix Web Application and Channels (WhatsApp, Web Chat Widget, Text Message, Email, Messenger, Mobile Chat, Facebook, Instagram, Instagram Direct).